пятница, 4 ноября 2011 г.

Weblogic 10.3.0 и не работающий SSL

На неподдерживаемой версии Java 1.6.0_13 и выше ssl на weblogic не поднимается с ошибкой
unsupported oid in the algorithmidentifier object weblogic

Порывшись в гугле, способ решения ошибки такой:

1. Ищем файл с сертификатами от jre: cacerts
2. Выводим в файл все сертификаты keytool -list -v -keystore cacerts -storepass changeit > cacerts.txt
3. Ищем внутри него все сертификаты SHA256withRSA
4. Удаляем сертификаты keytool -delete -keystore cacerts -alias ... -storepass changeit перезапускаем сервер

Примечание: до этого еще удалил сертификаты ttelesecglobalrootclass2ca, ttelesecglobalrootclass3ca

Комментариев нет: